Issue with payment processing
Incident Report for iwantmyname
Resolved
This incident has been resolved.
Posted Jan 13, 2020 - 06:32 UTC
Update
We are continuing to monitor for any further issues.
Posted Jan 11, 2020 - 15:03 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 11, 2020 - 00:28 UTC
Identified
We are currently having a timeout issue with the payment processor. This is affecting new registrations and adding or updating credit cards on accounts for Visa or Mastercard. (American Express is not affected.) We can register domains manually if the issue is urgent. Customers will need to contact our support team: https://iwantmyname.com/support
Posted Jan 10, 2020 - 14:59 UTC
This incident affected: Dashboard and Order processing.