Routine Maintenance
Incident Report for iwantmyname
Resolved
This incident has been resolved.
Posted Oct 01, 2019 - 05:13 UTC
Monitoring
As part of routine maintenance, we'll need to shut down the site for a a short time. All services will be offline during this period. I apologize for any inconvenience this causes.
Posted Oct 01, 2019 - 05:00 UTC
This incident affected: Website, Domain search, Dashboard, Order processing, and Blog.