Domain information unavailable
Incident Report for iwantmyname
Resolved
Issue has been resolved
Posted Apr 25, 2024 - 17:09 UTC
Investigating
We currently have a problem with checkouts domains services due to a problem with our upstream registrar. Next update will be at 6:30pm BST with a resolution
Posted Apr 25, 2024 - 16:10 UTC
This incident affected: Domain search and DNS hosting.