Issue with DNS and nameserver updates
Incident Report for iwantmyname
Resolved
The issue in our dashboard affecting updating of nameservers has now been resolved. I'd like to apologise for any inconvenience this caused.
Posted Jul 24, 2019 - 06:31 UTC
Investigating
There is an issue that's affecting the dashboard and preventing DNS and nameserver updates. May also see general site slowness. We're working on a fix now. Manual updates can be made via authenticated request: login to your account and send the details via https://iwantmyname.com/support.

This is a continuation of our ongoing problem from earlier.
Posted Jul 24, 2019 - 04:51 UTC
This incident affected: Dashboard.