Problem with upstream payment processor
Incident Report for iwantmyname
Resolved
Our upstream payment processor is back online. Thank you for bearing with us.
Posted Sep 18, 2020 - 03:34 UTC
Monitoring
Our payment processing gateway is experiencing issues at the moment. They are working to fix this as soon as possible and we'll provide an update as soon as this is resolved.

Only order processing is affected, and the rest of the site is running fine.
Posted Sep 18, 2020 - 03:25 UTC
This incident affected: Order processing.