Scheduled Server Maintenance
Incident Report for iwantmyname
Resolved
This incident has been resolved.
Posted Sep 30, 2021 - 08:09 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 29, 2021 - 11:34 UTC
Update
Our maintenance window is now complete and the site has been restored. Please report any issues to our support folks via the usual methods.
Posted Sep 29, 2021 - 11:34 UTC
Investigating
We're working on some internal improvements for our server setup. Our website and customer dashboard will be down for about two hours while we undertake this maintenance, and we'll let you know when it's complete.
Posted Sep 29, 2021 - 07:56 UTC
This incident affected: Website, Domain search, Dashboard, and Order processing.