Outage of iwantmyname website
Incident Report for iwantmyname
Resolved
We're back. Sorry for the inconvenience this has caused.
Posted over 1 year ago. Dec 07, 2017 - 00:28 UTC
Identified
We found the issue and should be up and running again shortly.
Posted over 1 year ago. Dec 07, 2017 - 00:26 UTC
Investigating
We are investigating an outage resulting in our website not loading
Posted over 1 year ago. Dec 07, 2017 - 00:18 UTC