Support system outage
Incident Report for iwantmyname
Resolved
Support system is back to regular service. Thank you for your patience.
Posted about 1 year ago. Jan 04, 2018 - 00:14 UTC
Identified
We are experiencing an upstream issue with our support system provider, which is limiting our ability to access and process support cases.

We will assist on basic issues where possible for now and will follow up as soon as it's resolved. All functions of iwantmyname's systems: domain search, registrations, billings, DNS dashboard, etc. are fully operational.
Posted about 1 year ago. Jan 03, 2018 - 22:05 UTC