Issue with DNS and nameserver updates
Incident Report for iwantmyname
Resolved
Dashboard is working again and DNS and nameserver updates are available.
Posted Jul 23, 2019 - 21:05 UTC
Identified
There is an issue that's affecting the dashboard and preventing DNS and nameserver updates. May also see general site slowness. We're working on a fix now. Manual updates can be made via authenticated request: login to your account and send the details via https://iwantmyname.com/support
Posted Jul 23, 2019 - 20:03 UTC
This incident affected: Dashboard and DNS hosting.