Problems with an upstream service
Incident Report for iwantmyname
Resolved
This incident has now been resolved. Thanks for your patience!
Posted Apr 30, 2020 - 05:58 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 30, 2020 - 01:07 UTC
Identified
One of our upstream partners is experiencing problems which is preventing DNS changes from being made at this time. We'll let you know once the issue is resolved. Thanks for your patience!
Posted Apr 30, 2020 - 01:07 UTC
This incident affected: Dashboard and DNS hosting.