Support form issues
Incident Report for iwantmyname
Resolved
Our support form is (finally!) back up and running. Thanks so much for your patience!
Posted Jun 03, 2021 - 08:48 UTC
Investigating
We are currently experiencing issues with our support form. In the meantime, please email help@support.iwantmyname.com so we can assist.
Posted May 30, 2021 - 20:47 UTC
This incident affected: Website.