Maintenance at our payment gateway
Incident Report for iwantmyname
Resolved
Maintenance is over​, thank you for your patience.
Posted 10 months ago. Oct 09, 2018 - 13:15 UTC
Monitoring
One of our technical partners is currently doing maintenance which has resulted in a partial outage. Existing domains are not affected, but payments may not be processed at the moment. The maintenance is scheduled to last until 13:00 UTC. Our apologies for the inconvenience.
Posted 10 months ago. Oct 09, 2018 - 11:25 UTC
This incident affected: Order processing.