Problems with new transactions
Incident Report for iwantmyname
Resolved
Transactions are working again. Thanks for your patience and sorry for the inconvenience.
Posted 12 months ago. Aug 23, 2018 - 14:44 UTC
Monitoring
We're having connection problems with one of our service providers, which means that some customers will have trouble buying new domains or updating their payment details at the moment. We're monitoring the problem and hope to have it resolved shortly.
Posted 12 months ago. Aug 23, 2018 - 14:19 UTC
This incident affected: Order processing.