Upstream maintenance
Incident Report for iwantmyname
Resolved
This incident has been resolved.
Posted May 21, 2022 - 11:18 UTC
Update
Upstream work at Hexonet, our DNS reseller and service provider is finished and services are now operational
Posted May 21, 2022 - 11:18 UTC
Investigating
Our upstream provider is under maintenance from 0700 UTC. During this time, domain search, order processing, and domain management in the dashboard may be affected. We should be back to normal by 1100 UTC: https://time.is/UTC
Posted May 21, 2022 - 04:54 UTC
This incident affected: Domain search, Dashboard, and Order processing.