Trouble connecting to a technical partner
Incident Report for iwantmyname
Resolved
The issue has been resolved. Thanks for your patience!
Posted about 1 year ago. Mar 02, 2018 - 04:15 UTC
Investigating
We're having connection problems with an upstream technical partner, and large parts of our site are having outages as a result. We're actively working to resolve this, and hope to have more information for you soon.
Posted about 1 year ago. Mar 02, 2018 - 03:00 UTC