Scheduled Maintenance
Incident Report for iwantmyname
Resolved
This incident has been resolved.
Posted Mar 04, 2023 - 16:50 UTC
Investigating
We're working on some internal improvements to the domain system this will result in degraded performance. We expect to be fully operational at 11:00 GMT. Thank you for your patience.
Posted Mar 04, 2023 - 08:46 UTC
This incident affected: Domain search and Dashboard.