Partner system outage causing issues

Incident Report for iwantmyname

Resolved

This incident has now been resolved. Thank you for your patience!
Posted Sep 04, 2019 - 07:38 UTC

Identified

Our partner system is currently experiencing an issue which is affecting our search functionality. We are in touch with them and monitoring performance.
Posted Sep 04, 2019 - 07:23 UTC
This incident affected: Domain search.