Problems updating billing information
Incident Report for iwantmyname
Resolved
This incident has been resolved.
Posted over 1 year ago. Dec 27, 2017 - 06:46 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted over 1 year ago. Dec 27, 2017 - 02:20 UTC
Investigating
We're having trouble connecting to one of our upstream providers related to billing information. The rest of the site is working fine, but users may experience difficulties with purchases and updating their billing information.
Posted over 1 year ago. Dec 27, 2017 - 01:57 UTC